<!DOCTYPE html><html class="page-html page-story top-menu--closed" data-evt="page-load" data-evt-typ="Screen View" data-evt-val='{"control_fields": {"mparticle": {"extra_keys": ["Category", "All Sub Sections", "Canonical Page Path", "Page Response Type", "Sub Section", "Sub Section 2", "Sub Section 3", "Meta Robots Tag", "Meta Description", "Division", "Metered Content Type", "MPID", "Session UUID", "Ad Blocker Enabled", "Device Type", "Entity", "Global Post ID", "Global Slug", "Original ID", "Originating Property", "Project Type", "Excerpt", "Modification Date", "Modification time of day", "Character Count", "Modification Timestamp"], "mp_native_event": true, "mp_custom_flags": ["Google.NonInteraction", "Google.Page"]}, "krux": {"extra_keys": ["Page Type", "View Type", "URL Parameters", "Alternate Headline"]}, "extra_keys": ["Main Category", "AdLight User", "Login Status", "MPID", "Paywall Whitelist", "Referral Details", "Article ID", "Article Title", "Authors", "Article Tags", "NLP Category", "NLP Entity", "NLP Topic", "Publish Date", "Publish Time of Day", "Wire Authors", "Wire Content", "Word Count", "Sponsor", "Publish Timestamp"]}}' data-page-type="story" lang="en-CA"><head> <script>
        document.cookie = "__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/";
        var setNptTechAdblockerCookie = function(adblocker) {
            var d = new Date();
            d.setTime(d.getTime() + 60 * 5 * 1000);
            document.cookie = "__adblocker=" + (adblocker ? "true" : "false") + "; expires=" + d.toUTCString() + "; path=/";
        };
        var script = document.createElement("script");
        script.setAttribute("async", true);
        script.setAttribute("src", "//www.npttech.com/advertising.js");
        script.setAttribute("onerror", "setNptTechAdblockerCookie(true);");
        document.getElementsByTagName("head")[0].appendChild(script);
    </script> <title>RCMP investigating human remains found in trail near Thickwood gazebo | Fort Mcmurray Today</title> <meta charset="utf-8"/> <meta content="IE=edge" http-equiv="X-UA-Compatible"/> <meta content="width=device-width,minimum-scale=1,initial-scale=1" name="viewport"/> <meta content="Investigators are combing a trail system in Thickwood after human remains were discovered on Saturday afternoon." name="description"/> <meta content="" name="google-site-verification"/>  <meta content="0417980f-6cb9-411e-99d9-f9f9cf20e773" name="vf:container_id"/> <link crossorigin="" href="https://fonts.gstatic.com" rel="preconnect"/> <link href="https://www.youtube.com/iframe_api" rel="dns-prefetch"/> <link href="https://fonts.googleapis.com/css?family=Roboto+Condensed:700%7CRoboto:400,700&amp;display=swap" rel="stylesheet"/> <style type="text/css">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</style> <style type="text/css">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</style> <style type="text/css">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</style> <noscript> <style>.lazyload {filter: blur(0);}</style> </noscript> <style type="text/css">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</style> <link href="https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood" rel="canonical"/> <link href="https://fortmcmurraytoday.prod.postmedia.digital/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood/wcm/0417980f-6cb9-411e-99d9-f9f9cf20e773/amp/" rel="amphtml"/> <link href="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/favicon.ico" rel="shortcut icon" type="image/x-icon"/> <link href="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/apple-touch-icons/iphone/icon.png" rel="apple-touch-icon"/> <link href="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/apple-touch-icons/iphone/icon.png" rel="apple-touch-icon-precomposed"/> <link href="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/apple-touch-icons/iphone/icon.png" rel="apple-touch-icon" sizes="120x120"/> <link href="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/apple-touch-icons/iphone/icon.png" rel="apple-touch-icon-precomposed" sizes="120x120"/> <link href="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/apple-touch-icons/ipad/icon.png" rel="apple-touch-icon" sizes="152x152"/> <link href="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/apple-touch-icons/ipad/icon.png" rel="apple-touch-icon-precomposed" sizes="152x152"/> <link href="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/apple-touch-icons/iphone-retina/icon.png" rel="apple-touch-icon" sizes="180x180"/> <link href="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/apple-touch-icons/iphone-retina/icon.png" rel="apple-touch-icon-precomposed" sizes="180x180"/> <link href="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/apple-touch-icons/ipad-retina/icon.png" rel="apple-touch-icon" sizes="167x167"/> <link href="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/apple-touch-icons/ipad-retina/icon.png" rel="apple-touch-icon-precomposed" sizes="167x167"/> <meta content="fortmcmurraytoday" property="og:site_name"/> <meta content="article" property="og:type"/>  <script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "url": "https://fortmcmurraytoday.com/news/local\u002Dnews/rcmp\u002Dinvestigating\u002Dhuman\u002Dremains\u002Dfound\u002Din\u002Dforested\u002Darea\u002Dnear\u002Dthickwood",
    "mainEntityOfPage": "https://fortmcmurraytoday.com/news/local\u002Dnews/rcmp\u002Dinvestigating\u002Dhuman\u002Dremains\u002Dfound\u002Din\u002Dforested\u002Darea\u002Dnear\u002Dthickwood",
    "headline": "RCMP investigating human remains found in trail near Thickwood gazebo",
    "datePublished": "March 21, 2021, 7:13 p.m.",
    "dateModified": "March 21, 2021, 7:42 p.m.",
    "description": "Investigators are combing a trail system in Thickwood after human remains were discovered on Saturday afternoon.",
    "author": {
        "@type": "Person",
        "name": "Vincent McDermott"
    },
    "publisher": {
        "@type": "Organization",
        "name": "Fort McMurray Today",
        "logo": {
            "@type": "ImageObject",
            "url": "https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/identity/logo-identity-fmt.svg"
        }
    }
    
    ,"image": {
        "@type": "ImageObject",
        "url": "https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg",
        "height": "667",
        "width": "1000"
    }
    
}
</script> <meta content="RCMP investigating human remains found in trail near Thickwood gazebo" property="og:title"/> <meta content="https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg" property="og:image"/> <meta content="667" property="og:image:width"/> <meta content="1000" property="og:image:height"/> <meta content="RCMP investigating human remains found in trail near Thickwood gazebo" name="twitter:title"/> <meta content="https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg" name="twitter:image"/> <meta content="summary_large_image" name="twitter:card"/> <meta content="https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood?ia_markup=1" property="ia:markup_url"/> <script id="page-data" type="application/json">
    
    {"identity": {"sso": {"account": "ztcpr5854s8kyh93khrgw44sv9", "application": "postmedia.us", "client": "tn96jz8fcpufp8qamppx8szj9ym8dvwr", "flowName": null, "flowVersion": null}, "logo": "https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/identity/logo-identity-fmt.svg", "theme_name": "communities", "links": {"privacy": {"link": "https://pages.postmedia.com/privacy-statement/", "title": "Privacy", "a_title": "Link to Postmedia Privacy Statement"}, "terms": {"link": "https://pages.postmedia.com/termsofservice/", "title": "Terms", "a_title": "Link to Postmedia Terms of Service"}, "copyright": {"link": "/copyright/", "title": "Copyright", "a_title": "Link to the Copyright page"}, "site_map": {"link": "/sitemap/", "title": "Site Map", "a_title": "Link to Site map"}, "contact_us": {"link": "/contact-us/", "title": "Contact Us", "a_title": "Link to Contact page"}}, "property": "Fort McMurray Today", "showPasswordPolicy": false}, "analytics": {"femVersion": "v29.1", "platformVersion": "6.0.2", "platform": "Cheetah", "brand": "Fort McMurray Today", "domain": "fortmcmurraytoday.com", "division": "communities", "provider": {"account": "a950360fecf39440ba003157b3984ba2"}, "isDev": false, "debug": "DCS | Analytics", "tags": {"gtm": ["GTM-MKM4ZNQ"], "krux": "uthtxmddg", "comScore": "10276888"}}, "ads": {"bidding": [{"account": "3528", "client": "amazon"}, {"account": "184635-69700543969858", "client": "ix"}], "lazy": false, "refresh": false, "property": "fmt", "provider": {"account": "3081"}, "site": "SMCO_ENCO_AB_FortMcMurrayToday_EN_WEB", "verifier": {"account": "928934"}}, "page": {"ancestry": ["news", "local-news"], "articleId": "0417980f-6cb9-411e-99d9-f9f9cf20e773", "authors": ["Vincent McDermott"], "writers": {"main": [{"name": "Vincent McDermott"}], "wire": []}, "wireId": "", "date": {"mod": "2021-03-21T19:42:04+00:00", "pub": "2021-03-21T19:13:15+00:00", "pub_timestamp": 1616353995, "mod_timestamp": 1616355724}, "dist": "Fort McMurray Today", "excerpt": "Investigators are combing a trail system in Thickwood after human remains were discovered on Saturday afternoon.", "isOrigin": false, "klangoo": {"created": "2021-03-21T19:13:17.922795", "properties": {"lang": "en"}, "summary": "The area was closed off by police and the remains were removed.An", "keyTopics": [{"text": "human remains", "score": 0.9959}, {"text": "Crime Stoppers", "score": 0.929}, {"text": "Saturday afternoon.Wood Buffalo RCMP", "score": 0.8751}, {"text": "criminal activity", "score": 0.8202}, {"text": "police", "score": 0.8069}, {"text": "trail system", "score": 0.5853}, {"text": "Rotary Club Gazebo", "score": 0.5853}, {"text": "Thicket Drive", "score": 0.5853}, {"text": "Silin Forest road", "score": 0.5853}], "entities": [{"rank": "VR", "type": "People", "score": 0.9337, "token": "Wood Buffalo RCMP", "typeID": "18", "subtype": "person name", "entityID": 3977300731}, {"rank": "R", "type": "Artifacts", "score": 0.5896, "token": "Silin Forest road", "typeID": "1", "subtype": "artifact", "entityID": 2853793652}, {"rank": "R", "type": "Associations & groups", "score": 0.5896, "token": "Rotary Club", "typeID": "2", "subtype": "group", "entityID": 44451}, {"rank": "R", "type": "People", "score": 0.5764, "token": "Alberta RCMP", "typeID": "18", "subtype": "person name", "entityID": 1514519003}, {"rank": "R", "type": "People", "score": 0.5764, "token": "Wood Buffalo", "typeID": "18", "subtype": "person name", "entityID": 1707996284}], "categories": [{"name": "Law Enforcement", "score": 4.56, "specificCategories": [{"name": "Crime|Law Enforcement", "score": 4.56}]}], "sensitiveContent": {"categories": [{"name": "Politics_Canada"}, {"name": "Crime"}]}, "negativeKeywords": [{"brand": "GM", "broadMatch": [], "phraseMatch": ["Police", "club", "death"]}, {"brand": "JLR", "broadMatch": [], "phraseMatch": ["police", "death"]}, {"brand": "Hyundai", "broadMatch": [], "phraseMatch": ["Death"]}, {"brand": "BLM", "broadMatch": [], "phraseMatch": ["death"]}, {"brand": "QuestTradeNegative", "broadMatch": [], "phraseMatch": ["death", "crime"]}]}, "kw": ["Google news keyword"], "originId": "1258959", "paywall": "", "tags": [], "title": {"main": "RCMP investigating human remains found in trail near Thickwood gazebo", "alt": null}, "type": "story", "wc": 127, "charCount": 691, "isPremium": false, "isPaywallWhitelisted": false, "siteName": "fortmcmurraytoday", "globalSlug": "0325 fm bodyfound", "projectType": "Newsroom weekly", "responseStatus": 200}}
</script> <script>
    var modern_script_elem, legacy_script_elem, ytAdTargetingLoadEvent, script_onload
    window.ytVideoAdTargetingConfig = window.ytVideoAdTargetingConfig || {}
    if (typeof (Event) === 'function') {
        ytAdTargetingLoadEvent = new Event('yt_ad_targeting_load_event');
    } else {
        ytAdTargetingLoadEvent = document.createEvent('Event');
        ytAdTargetingLoadEvent.initEvent('yt_ad_targeting_load_event', false, false);
    }

    script_onload = function () {
        FrontEndModules.initPage(JSON.parse(document.getElementById('page-data').innerHTML));
        // get Video AdTargeting Config  and then dispatch `ias_data_load_event`
        window.ytVideoAdTargetingConfig = FrontEndModules.getAdTargetingConfig(JSON.parse(document.getElementById('page-data').innerHTML));
        try {
            window.ytVideoAdTargetingConfig.adTargetingParams += encodeURIComponent('&cheetah=y'); // we need this extra flag for cheetah
        }
        catch (error) {
            console.error(error);
        }
        window.dispatchEvent(ytAdTargetingLoadEvent);
    }

    var locSrc = 'https://fem.prod.postmedia.digital/v29.1/';

    legacy_script_elem = document.createElement('script')
    legacy_script_elem.async = true
    legacy_script_elem.noModule = true
    legacy_script_elem.onload = script_onload
    legacy_script_elem.src = locSrc + 'fem.legacy.js'
    document.head.appendChild(legacy_script_elem)

    modern_script_elem = document.createElement('script')
    modern_script_elem.async = true
    modern_script_elem.type = "module"
    modern_script_elem.onload = script_onload
    modern_script_elem.src = locSrc + 'fem.js'
    document.head.appendChild(modern_script_elem)
</script> </head> <body class="" data-django-static-root="https://dcs-static.prod.postmedia.digital/6.0.2/"> <a class="skip-to" href="#main-content">Skip to Content</a> <div aria-hidden="true" class="ad__high-impact ad__container"> <div class="ad__inner__container" data-ad="[[728,91],[970,251]]" data-ad-high-impact="" data-ad-loc="1" data-ad-target='{"hie":["y"]}' id="ad-high-impact"> </div> </div>  <div class="sticky--header"> <header class="header" id="header"> <div class="row fluid"> <div class="header__left col-xs-2 col-sm-4"> <button aria-controls="sidebar" aria-expanded="false" aria-haspopup="true" aria-label="Open Main Menu" class="top-menu-button" type="button"> <span class="top-menu-button__wrapper"> <span aria-hidden="true" class="top-menu-button__icon"><span></span></span> <span class="top-menu-button__text hidden-small-down">Sections</span> </span> </button> <div class="top-menu-search hidden-small-down" id="top-menu-search" role="search"> <button aria-controls="top-menu-search__form" aria-expanded="false" aria-haspopup="true" aria-label="Open Search Form" class="top-menu-search__button" type="button"> <span class="top-menu-button__wrapper"> <span aria-hidden="true"> <svg viewBox="0 0 32 32"> <path d="M 12 1 C 5.9418624 1 1 5.9418624 1 12 C 1 18.058138 5.9418624 23 12 23 C 14.250876 23 16.345333 22.314679 18.091797 21.146484 L 27.939453 30.994141 A 2.0002 2.0002 0 1 0 30.767578 28.166016 L 20.957031 18.355469 C 22.23773 16.557441 23 14.367054 23 12 C 23 5.9418624 18.058138 1 12 1 z M 12 3.8691406 C 16.507309 3.8691406 20.130859 7.4926906 20.130859 12 C 20.130859 16.507309 16.507309 20.130859 12 20.130859 C 7.4926906 20.130859 3.8691406 16.507309 3.8691406 12 C 3.8691406 7.4926906 7.4926906 3.8691406 12 3.8691406 z"></path> </svg> </span> <span class="top-menu-button__text hidden-small-down">Search</span> </span> </button> <form action="/search/" class="top-menu-search__form top-menu-search__form--hidden" id="top-menu-search__form" method="get"> <label class="visually-hidden" for="id_search_text">Search fortmcmurraytoday.com</label> <div class="search-form form__group"> <input class="form__control" id="id_search_text" name="search_text" placeholder="Search " required="" type="text" value=""/> <button class="button button--icon" type="submit"> <span aria-hidden="true"> <svg viewBox="0 0 32 32"> <path d="M 12 1 C 5.9418624 1 1 5.9418624 1 12 C 1 18.058138 5.9418624 23 12 23 C 14.250876 23 16.345333 22.314679 18.091797 21.146484 L 27.939453 30.994141 A 2.0002 2.0002 0 1 0 30.767578 28.166016 L 20.957031 18.355469 C 22.23773 16.557441 23 14.367054 23 12 C 23 5.9418624 18.058138 1 12 1 z M 12 3.8691406 C 16.507309 3.8691406 20.130859 7.4926906 20.130859 12 C 20.130859 16.507309 16.507309 20.130859 12 20.130859 C 7.4926906 20.130859 3.8691406 16.507309 3.8691406 12 C 3.8691406 7.4926906 7.4926906 3.8691406 12 3.8691406 z"></path> </svg> </span> <span class="visually-hidden">Perform search</span> </button> </div> </form> </div> </div> <div class="header__center col-xs-8 col-sm-4"> <a class="header-logo" href="/" title="Link to Home page"> <svg aria-labelledby="fmtLogo" class="header-logo-image logo-fmt" role="img" viewBox="0 0 526.06 206.75" x="0" xmlns="http://www.w3.org/2000/svg" y="0"> <title id="fmtLogo">Fort McMurray Today</title><style>.st2{fill:#fff}</style><path d="M22.21 1.71s-20.5 0-20.5 20.5v162.32s0 20.5 20.5 20.5h481.63s20.5 0 20.5-20.5V22.21s0-20.5-20.5-20.5H22.21z" fill="#00548f"></path><linearGradient gradientTransform="matrix(308.881 0 0 -308.881 40512.926 165706.39)" gradientUnits="userSpaceOnUse" id="SVGID_1_" x1="-131.163" x2="-129.455" y1="536.139" y2="536.139"><stop offset="0" stop-color="#010101"></stop><stop offset=".029" stop-color="#232323"></stop><stop offset=".095" stop-color="#646362"></stop><stop offset=".16" stop-color="#c2c1c1"></stop><stop offset=".189" stop-color="#b0afaf"></stop><stop offset=".245" stop-color="#8a8988"></stop><stop offset=".323" stop-color="#565454"></stop><stop offset=".417" stop-color="#191a19"></stop><stop offset=".442" stop-color="#010101"></stop><stop offset=".449" stop-color="#0d0d0d"></stop><stop offset=".516" stop-color="#504f4e"></stop><stop offset=".571" stop-color="#878585"></stop><stop offset=".61" stop-color="#afaeae"></stop><stop offset=".63" stop-color="#c2c1c1"></stop><stop offset=".834" stop-color="#c2c1c1"></stop><stop offset=".851" stop-color="#b0afaf"></stop><stop offset=".884" stop-color="#8a8988"></stop><stop offset=".93" stop-color="#565454"></stop><stop offset=".985" stop-color="#191a19"></stop><stop offset="1" stop-color="#010101"></stop></linearGradient><path d="M22.21 1.71v1.71c-.02.1-18.78-.1-18.8 18.79v162.32c.1.02-.1 18.78 18.8 18.8h481.63c.02-.1 18.78.1 18.8-18.8V22.21c-.1-.02.1-18.78-18.8-18.79H22.21V0h481.63c22.11.13 22.19 22.2 22.21 22.21v162.32c-.13 22.11-22.2 22.19-22.21 22.21H22.21C.1 206.62.02 184.54 0 184.53V22.21C.13.1 22.2.02 22.21 0v1.71z" fill="url(#SVGID_1_)"></path><g><path class="st2" d="M19.7 31.26h-3.47v-5.39h3.47v-2.03c0-3.8 1.02-7.11 9.87-7.11 1.97 0 3.89.09 4.3.13v5.65c-.42-.04-1.26-.09-1.79-.09-1.67 0-2.63.31-2.63 1.99v1.46h4.31v5.39h-4.31V49.5H19.7V31.26zM34.3 37.62c0-8.65 5.44-12.1 12.56-12.1 7 0 12.56 3.44 12.56 12.1 0 8.52-5.56 12.19-12.56 12.19-7.06 0-12.56-3.66-12.56-12.19zm15.3 0c0-5.12-.6-6.58-2.75-6.58-2.03 0-2.81 1.1-2.81 6.58 0 5.08.66 6.89 2.81 6.89 2.04 0 2.75-1.37 2.75-6.89zM61.81 25.88h9.81v3.71h.06c1.14-2.03 3.29-4.06 6.82-4.06.36 0 .78.04.78.04v6.8c-.36-.04-1.08-.13-1.55-.13-2.87 0-5.14.66-6.1 1.19V49.5h-9.81V25.88zM83.4 44.16v-12.9h-3.41v-5.39h3.41v-7.99h9.75v7.99h5.38v5.39h-5.38v10.6c0 2.3.72 2.56 2.87 2.56.84 0 2.03-.13 2.21-.18v5.12c-.54.13-3.17.31-5.62.31-6.64.01-9.21-1.49-9.21-5.51zM112.29 25.88h9.81v2.87c1.32-1.41 4.48-3.22 7.71-3.22 3.35 0 5.26.84 5.92 3.27 1.49-1.55 4.72-3.27 7.83-3.27 4.13 0 6.28 1.5 6.28 5.52V49.5h-9.81V33.47c0-1.02-.3-1.55-1.38-1.55-.96 0-1.85.53-2.69.93V49.5h-9.81V33.47c0-1.02-.3-1.55-1.32-1.55s-2.03.53-2.75.93V49.5h-9.81V25.88zM152.36 37.71c0-8.66 5.62-12.19 12.5-12.19 7.59 0 10.46 3.49 11.42 8.7l-9.03.97c-.36-2.83-.9-4.15-2.45-4.15-1.91 0-2.69 1.19-2.69 6.67 0 5.3.6 6.84 2.63 6.84 1.67 0 2.51-1.24 2.87-4.5l8.73.88c-.84 5.17-4.13 8.92-11.66 8.92-6.94 0-12.32-3.62-12.32-12.14zM178.61 25.88h9.81v2.87c1.32-1.41 4.49-3.22 7.71-3.22 3.35 0 5.26.84 5.92 3.27 1.5-1.55 4.72-3.27 7.83-3.27 4.13 0 6.28 1.5 6.28 5.52V49.5h-9.81V33.47c0-1.02-.3-1.55-1.38-1.55-.96 0-1.85.53-2.69.93V49.5h-9.81V33.47c0-1.02-.3-1.55-1.32-1.55s-2.03.53-2.75.93V49.5h-9.81V25.88z"></path><g><path class="st2" d="M219.76 44.47V25.88h9.75V42c0 1.02.42 1.55 1.43 1.55 1.08 0 2.15-.53 2.93-.93V25.88h9.81V49.5h-9.81v-2.91c-1.38 1.41-4.49 3.22-7.95 3.22-3.65 0-6.16-1.06-6.16-5.34zM247.39 25.88h9.81v3.71h.06c1.14-2.03 3.29-4.06 6.82-4.06.36 0 .78.04.78.04v6.8c-.36-.04-1.08-.13-1.55-.13-2.87 0-5.14.66-6.1 1.19V49.5h-9.81V25.88z"></path></g><g><path class="st2" d="M266.41 25.88h9.81v3.71h.06c1.14-2.03 3.29-4.06 6.82-4.06.36 0 .78.04.78.04v6.8c-.36-.04-1.08-.13-1.55-.13-2.87 0-5.14.66-6.1 1.19V49.5h-9.81V25.88zM284.29 43.32c0-5.21 6.64-8.39 14.05-9.49v-.62c0-1.33-.3-1.77-1.97-1.77-2.21 0-5.14 1.32-6.52 2.16l-4.54-4.59c3.47-2.3 8.19-3.49 12.86-3.49 7.06 0 9.57 2.43 9.57 7.33v10.91c0 2.83.18 4.55.66 5.74h-9.57c-.3-.75-.48-1.63-.48-3.14-1.55 2.03-3.77 3.36-7.18 3.36-3.65 0-6.88-1.63-6.88-6.4zm14.05-.18v-4.5c-2.87.71-4.66 1.81-4.66 3.49 0 1.15.72 1.81 1.85 1.81 1.26 0 2.27-.53 2.81-.8z"></path></g><g><path class="st2" d="M307.73 57.8l1.62-5.83c.84.13 1.97.31 3.41.31 1.97 0 2.63-.4 3.05-1.55l.42-1.15-7.96-23.71h10.17l1.91 9.89c.36 1.94.48 2.91.9 6.23h.24c.42-3.05.6-4.33 1.02-6.18l2.15-9.94h9.33l-8.97 25.61c-1.61 4.64-4.07 6.93-10.35 6.93-3.35.01-5.56-.3-6.94-.61z"></path></g></g><g><path class="st2" d="M43.21 85.33H17.13V62.85h88.04v22.49H79.09v91.49H43.21v-91.5zM105.58 119.83c0-42.2 21.49-58.37 52.16-58.37 30.46 0 51.95 16.17 51.95 58.37 0 42.2-21.49 58.22-51.95 58.22-30.67.01-52.16-16.01-52.16-58.22zm67.8 0c0-24.49-3.75-34.96-15.65-34.96-12.1 0-15.85 10.47-15.85 34.96 0 24.49 3.75 35.58 15.85 35.58 11.89.01 15.65-11.08 15.65-35.58zM218.23 62.85h36.72c35.88 0 61.75 8.47 61.75 56.68 0 48.67-26.49 57.3-61.75 57.3h-36.72V62.85zm41.1 91.95c17.32 0 21.07-7.55 21.07-35.27 0-27.42-3.75-34.19-21.28-34.19h-5.01v69.46h5.22zM343.82 176.82h-30.88l33.38-114.44h35.88l33.38 114.44h-35.05l-4.8-21.41h-27.12l-4.79 21.41zm26.91-42.97c-2.92-12.63-5.42-20.64-8.14-39.28h-.83c-2.5 18.64-5.01 26.18-7.93 38.66l-1.04 4.31h18.78l-.84-3.69z"></path><g><path class="st2" d="M432.9 137.24l-33.8-74.39h36.3l16.69 45.44h.83l16.69-45.44h33.38l-34.21 74.39v39.58H432.9v-39.58z"></path></g></g></svg> </a> </div> <div class="header__right col-xs-2 col-sm-4"> <div class="share-button__wrapper share-button__wrapper--text hidden-large-down"> <button aria-expanded="false" aria-haspopup="true" aria-label="Open more share options" class="share-button flex-align-justify-center" type="button"> <span aria-hidden="true" class="share-button__icon"> <svg height="20" version="1.1" viewBox="0 0 14 20" width="14" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"> <path d="M10.38 7.2L14 7.2 14 20 0 20 0 7.2 3.6 7.2 3.6 8.89 1.85 8.89 1.85 18.31 12.15 18.31 12.15 8.89 10.38 8.89 10.38 7.2ZM7 0L12.25 4.8 11.01 5.93 7.87 3.06 7.87 12.3 6.12 12.3 6.12 3.06 2.99 5.93 1.75 4.8 7 0Z"></path> </svg> </span> <span class="share-button__text">Share</span> </button> <section aria-labelledby="shareModalSiteHeaderTitle" aria-modal="true" class="share-button__modal hidden-large-down" id="shareModalSiteHeader" role="dialog"> <button class="share-button__modal-close" type="button"> <img alt="Close" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/share-modal-icon-close.svg"/> </button> <h2 class="share-button__modal-title" id="shareModalSiteHeaderTitle"> Share this Story: <span class="hidden-medium-up">RCMP investigating human remains found in trail near Thickwood gazebo</span> </h2> <ul class="share-button__modal-items list-unstyled noskimlinks"> <li class="share-button__modal-item share-button__modal-item--link"> <a class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "Copy Link", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood"> <span aria-hidden="true" class="share-button__modal-item-icon"> <span class="copy"><svg height="48" version="1.1" viewBox="0 0 48 48" width="48" xmlns="http://www.w3.org/2000/svg"><g fill="none" fill-rule="evenodd" stroke="none" stroke-width="1"><g fill="#191919"><path d="M48 24C48 37.3 37.3 48 24 48 10.7 48 0 37.3 0 24 0 10.7 10.7 0 24 0 37.3 0 48 10.7 48 24"></path></g><path d="M32.5 28.7C32.5 28.4 32.4 28.1 32.1 27.8L29.3 25C29.1 24.8 28.8 24.6 28.4 24.6 28.1 24.6 27.7 24.8 27.5 25.1 27.5 25.1 27.6 25.2 27.7 25.3 27.9 25.5 28 25.6 28 25.6 28.1 25.7 28.1 25.7 28.2 25.9 28.3 26 28.4 26.1 28.4 26.2 28.4 26.3 28.4 26.4 28.4 26.6 28.4 26.9 28.3 27.2 28.1 27.5 27.8 27.7 27.5 27.9 27.1 27.9 27 27.9 26.9 27.8 26.8 27.8 26.7 27.8 26.5 27.7 26.4 27.6 26.3 27.6 26.2 27.5 26.2 27.4 26.1 27.4 26 27.3 25.9 27.1 25.8 27 25.7 26.9 25.6 26.9 25.3 27.2 25.2 27.5 25.2 27.9 25.2 28.2 25.3 28.5 25.6 28.8L28.3 31.6C28.6 31.8 28.9 31.9 29.2 31.9 29.6 31.9 29.9 31.8 30.2 31.6L32.1 29.6C32.4 29.4 32.5 29.1 32.5 28.7ZM23.1 19.3C23.1 18.9 23 18.6 22.7 18.4L20 15.6C19.7 15.3 19.4 15.2 19 15.2 18.7 15.2 18.4 15.3 18.1 15.6L16.2 17.5C15.9 17.8 15.8 18.1 15.8 18.4 15.8 18.8 15.9 19.1 16.2 19.3L18.9 22.1C19.2 22.4 19.5 22.5 19.9 22.5 20.2 22.5 20.6 22.3 20.8 22.1 20.8 22 20.7 22 20.6 21.8 20.4 21.7 20.3 21.6 20.3 21.5 20.2 21.5 20.2 21.4 20.1 21.3 20 21.2 19.9 21.1 19.9 20.9 19.9 20.8 19.9 20.7 19.9 20.6 19.9 20.2 20 19.9 20.2 19.7 20.5 19.4 20.8 19.3 21.1 19.3 21.3 19.3 21.4 19.3 21.5 19.3 21.6 19.4 21.7 19.4 21.9 19.5 22 19.6 22.1 19.7 22.1 19.7 22.2 19.8 22.3 19.9 22.4 20 22.5 20.1 22.6 20.2 22.6 20.3 22.9 20 23.1 19.6 23.1 19.3ZM33.9 26C34.7 26.7 35.1 27.6 35.1 28.7 35.1 29.8 34.7 30.7 33.9 31.4L32 33.4C31.2 34.1 30.3 34.5 29.2 34.5 28.2 34.5 27.3 34.1 26.5 33.4L23.8 30.6C23 29.8 22.6 28.9 22.6 27.9 22.6 26.8 23 25.8 23.8 25.1L22.6 23.9C21.9 24.7 20.9 25.1 19.9 25.1 18.8 25.1 17.9 24.7 17.1 23.9L14.3 21.2C13.6 20.4 13.2 19.5 13.2 18.4 13.2 17.4 13.6 16.5 14.4 15.7L16.3 13.8C17.1 13 18 12.6 19 12.6 20.1 12.6 21 13 21.8 13.8L24.5 16.6C25.3 17.3 25.6 18.2 25.6 19.3 25.6 20.4 25.3 21.3 24.5 22.1L25.6 23.3C26.4 22.5 27.3 22.1 28.4 22.1 29.5 22.1 30.4 22.4 31.2 23.2L33.9 26Z" fill="#FFFFFF" fill-rule="nonzero"></path></g></svg> </span> <span class="copied"><svg height="48" version="1.1" viewBox="0 0 48 48" width="48" xmlns="http://www.w3.org/2000/svg"><g fill="none" fill-rule="evenodd" stroke="none" stroke-width="1"><g fill="#005A8C"><path d="M48 24C48 37.3 37.3 48 24 48 10.7 48 0 37.3 0 24 0 10.7 10.7 0 24 0 37.3 0 48 10.7 48 24"></path></g><g fill="#FFFFFF" fill-rule="nonzero" transform="translate(15.000000, 12.000000)"><path d="M15.8 3L12 3C12 1.3 10.7 0 9 0 7.3 0 6 1.3 6 3L2.3 3C1 3 0 4 0 5.3L0 21.8C0 23 1 24 2.3 24L15.8 24C17 24 18 23 18 21.8L18 5.3C18 4 17 3 15.8 3ZM9 1.9C9.6 1.9 10.1 2.4 10.1 3 10.1 3.6 9.6 4.1 9 4.1 8.4 4.1 7.9 3.6 7.9 3 7.9 2.4 8.4 1.9 9 1.9ZM14.7 12.7L8 19.4C7.8 19.6 7.4 19.6 7.2 19.4L3.3 15.5C3.1 15.3 3.1 14.9 3.3 14.7L4.6 13.4C4.9 13.1 5.2 13.1 5.4 13.4L7.6 15.5 12.6 10.6C12.8 10.4 13.1 10.4 13.4 10.6L14.7 11.9C14.9 12.2 14.9 12.5 14.7 12.7Z"></path></g></g></svg> </span> </span> <span class="share-button__modal-item-text">Copy Link</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--email"> <a aria-label="Share via email" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "email", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="mailto:?Subject=I%20saw%20this%20on%20Fort%20McMurray%20Today&amp;Body=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood"> <img alt="Email" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-circle-email.svg" width="32"/> <span class="share-button__modal-item-text">Email</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--facebook"> <a aria-label="Share on Facebook" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "facebook", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="http://www.facebook.com/sharer.php?u=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;display=popup" rel="noopener" target="_blank"> <img alt="Facebook" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-fb.svg" width="32"/> <span class="share-button__modal-item-text">Facebook</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--twitter"> <a aria-label="Share on Twitter" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "twitter", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://twitter.com/share?url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;text=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo" rel="noopener" target="_blank"> <img alt="Twitter" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-tw.svg" width="32"/> <span class="share-button__modal-item-text">Twitter</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--reddit"> <a aria-label="Share on Reddit" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "reddit", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="http://www.reddit.com/submit?url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;smid=re-share&amp;title=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo" rel="noopener" target="_blank"> <img alt="Reddit" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-rdit.svg" width="32"/> <span class="share-button__modal-item-text">Reddit</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--pinterest"> <a aria-label="Share on Pinterest" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "pinterest", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://pinterest.com/pin/create/button/?url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;description=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo&amp;media=https%3A//smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg" rel="noopener" target="_blank"> <img alt="Pinterest" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-pin.svg" width="32"/> <span class="share-button__modal-item-text">Pinterest</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--linkedin"> <a aria-label="Share on LinkedIn" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "linkedin", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;title=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo" rel="noopener" target="_blank"> <img alt="LinkedIn" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-li.svg" width="32"/> <span class="share-button__modal-item-text">LinkedIn</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--tumblr"> <a aria-label="Share on Tumblr" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "tumblr", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://tumblr.com/widgets/share/tool?canonicalUrl=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;name=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo&amp;description" rel="noopener" target="_blank"> <img alt="Tumblr" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-tblr.svg" width="32"/> <span class="share-button__modal-item-text">Tumblr</span> </a> </li> </ul> </section> </div> <div class="sso-btns" data-sso-btns="" data-sso-marker=""></div> </div> </div> </header> </div> <div class="top-menu-wrapper"> <nav aria-labelledby="sidebar-title" class="top-menu" hidden="" id="sidebar"> <span class="visually-hidden" id="sidebar-title">Main Menu</span> <div class="top-menu-search hidden-small-up" role="search"> <form action="/search/" class="search-form--lg" method="get"> <label class="visually-hidden" for="id_search_text_top">Search fortmcmurraytoday.com</label> <div class="search-form form__group"> <input class="form__control" id="id_search_text_top" name="search_text" placeholder="Search fortmcmurraytoday.com" required="" type="text" value=""/> <button class="button button--icon" type="submit"> <span aria-hidden="true"> <svg viewBox="0 0 32 32"> <path d="M 12 1 C 5.9418624 1 1 5.9418624 1 12 C 1 18.058138 5.9418624 23 12 23 C 14.250876 23 16.345333 22.314679 18.091797 21.146484 L 27.939453 30.994141 A 2.0002 2.0002 0 1 0 30.767578 28.166016 L 20.957031 18.355469 C 22.23773 16.557441 23 14.367054 23 12 C 23 5.9418624 18.058138 1 12 1 z M 12 3.8691406 C 16.507309 3.8691406 20.130859 7.4926906 20.130859 12 C 20.130859 16.507309 16.507309 20.130859 12 20.130859 C 7.4926906 20.130859 3.8691406 16.507309 3.8691406 12 C 3.8691406 7.4926906 7.4926906 3.8691406 12 3.8691406 z"></path> </svg> </span> <span class="visually-hidden">Perform search</span> </button> </div> </form> </div> <ul class="top-menu__list-1" id="main-menu"> <li class="top-menu__item"> <a href="/category/news/"> <span class="top-menu__item__text">News</span> <span aria-hidden="true" class="arrow-right"></span> </a> <ul aria-label="News" class="top-menu__list-2"> <li class="top-menu__item"> <a href="/category/news/local-news/"> <span class="top-menu__item__text">Local News</span> </a> </li> <li class="top-menu__item"> <a href="/category/news/national/"> <span class="top-menu__item__text">Canada</span> </a> </li> <li class="top-menu__item"> <a href="/category/news/provincial/"> <span class="top-menu__item__text">Provincial</span> </a> </li> <li class="top-menu__item"> <a href="/category/news/world/"> <span class="top-menu__item__text">World</span> </a> </li> <li class="top-menu__item"> <a href="http://postpandemic.nationalpost.com/" rel="noopener" target="_blank"> <span class="top-menu__item__text">PostPandemic</span> <span aria-hidden="true" class="external-link"></span> </a> </li> <li class="top-menu__item"> <a href="/category/special-sections/"> <span class="top-menu__item__text">Special-Sections</span> </a> </li> <li class="top-menu__item"> <a href="/category/real-estate/"> <span class="top-menu__item__text">Real-Estate</span> </a> </li> </ul> </li> <li class="top-menu__item"> <a href="/category/sports/"> <span class="top-menu__item__text">Sports</span> <span aria-hidden="true" class="arrow-right"></span> </a> <ul aria-label="Sports" class="top-menu__list-2"> <li class="top-menu__item"> <a href="/category/sports/local-sports/"> <span class="top-menu__item__text">Local Sports</span> </a> </li> <li class="top-menu__item"> <a href="/category/sports/baseball/"> <span class="top-menu__item__text">Baseball</span> </a> </li> <li class="top-menu__item"> <a href="/category/sports/basketball/"> <span class="top-menu__item__text">Basketball</span> </a> </li> <li class="top-menu__item"> <a href="/category/sports/curling/"> <span class="top-menu__item__text">Curling</span> </a> </li> <li class="top-menu__item"> <a href="/category/sports/soccer/"> <span class="top-menu__item__text">Soccer</span> </a> </li> <li class="top-menu__item"> <a href="/category/sports/football/"> <span class="top-menu__item__text">Football</span> </a> </li> <li class="top-menu__item"> <a href="/category/sports/hockey/"> <span class="top-menu__item__text">Hockey</span> </a> </li> <li class="top-menu__item"> <a href="/category/sports/auto-racing/"> <span class="top-menu__item__text">Auto Racing</span> </a> </li> <li class="top-menu__item"> <a href="/category/sports/other-sports/"> <span class="top-menu__item__text">Other Sports</span> </a> </li> </ul> </li> <li class="top-menu__item"> <a href="/category/entertainment/"> <span class="top-menu__item__text">Entertainment</span> <span aria-hidden="true" class="arrow-right"></span> </a> <ul aria-label="Entertainment" class="top-menu__list-2"> <li class="top-menu__item"> <a href="/category/entertainment/local-arts/"> <span class="top-menu__item__text">Local Entertainment</span> </a> </li> <li class="top-menu__item"> <a href="/category/entertainment/movies/"> <span class="top-menu__item__text">Movies</span> </a> </li> <li class="top-menu__item"> <a href="/category/entertainment/music/"> <span class="top-menu__item__text">Music</span> </a> </li> <li class="top-menu__item"> <a href="/category/entertainment/television/"> <span class="top-menu__item__text">Television</span> </a> </li> <li class="top-menu__item"> <a href="/category/entertainment/books/"> <span class="top-menu__item__text">Books</span> </a> </li> <li class="top-menu__item"> <a href="/category/entertainment/gaming/"> <span class="top-menu__item__text">Gaming</span> </a> </li> <li class="top-menu__item"> <a href="/category/entertainment/celebrity/"> <span class="top-menu__item__text">Celebrities</span> </a> </li> </ul> </li> <li class="top-menu__item"> <a href="/category/life/"> <span class="top-menu__item__text">Life</span> <span aria-hidden="true" class="arrow-right"></span> </a> <ul aria-label="Life" class="top-menu__list-2"> <li class="top-menu__item"> <a href="/category/travel/"> <span class="top-menu__item__text">Travel</span> </a> </li> <li class="top-menu__item"> <a href="/category/life/food/"> <span class="top-menu__item__text">Food</span> </a> </li> <li class="top-menu__item"> <a href="/category/health/"> <span class="top-menu__item__text">Health</span> </a> </li> <li class="top-menu__item"> <a href="/category/contests/"> <span class="top-menu__item__text">Contests</span> </a> <ul aria-label="Contests" class="top-menu__list-3"> <li class="top-menu__item"> <a href="/category/contests/national-contests/"> <span class="top-menu__item__text">National Contests</span> </a> </li> </ul> </li> </ul> </li> <li class="top-menu__item"> <a href="/category/business/"> <span class="top-menu__item__text">Money</span> </a> </li> <li class="top-menu__item"> <a href="/category/opinion/"> <span class="top-menu__item__text">Opinion</span> <span aria-hidden="true" class="arrow-right"></span> </a> <ul aria-label="Opinion" class="top-menu__list-2"> <li class="top-menu__item"> <a href="/category/opinion/columnists/"> <span class="top-menu__item__text">Column</span> </a> </li> <li class="top-menu__item"> <a href="/category/opinion/editorials/"> <span class="top-menu__item__text">Editorial</span> </a> </li> <li class="top-menu__item"> <a href="/category/opinion/letters/"> <span class="top-menu__item__text">Letters</span> </a> </li> </ul> </li> <li class="top-menu__item"> <a href="http://postpandemic.nationalpost.com/" rel="noopener" target="_blank"> <span class="top-menu__item__text">COVID Changemakers</span> <span aria-hidden="true" class="external-link"></span> </a> </li> <li class="top-menu__item"> <a href="/all-newspapers/"> <span class="top-menu__item__text">All Newspapers</span> </a> </li> <li class="top-menu__item"> <a href="/category/driving/"> <span class="top-menu__item__text">Driving</span> </a> </li> <li class="top-menu__item"> <a href="/category/healthing/"> <span class="top-menu__item__text">Healthing</span> </a> </li> <li class="top-menu__item"> <a href="/category/thegrowthop/"> <span class="top-menu__item__text">The Growthop</span> </a> </li> <li class="top-menu__item"> <a href="/classifieds/"> <span class="top-menu__item__text">Classifieds</span> </a> </li> <li class="top-menu__item"> <a href="/remembering/"> <span class="top-menu__item__text">Obituaries</span> </a> </li> <li class="top-menu__item"> <a href="/shopping/"> <span class="top-menu__item__text">Shopping</span> </a> </li> <li class="top-menu__item"> <a href="/manage/"> <span class="top-menu__item__text">Manage Print Subscription</span> </a> </li> </ul> </nav> </div> <nav aria-label="secondary menu" class="secondary-nav secondary-nav--story" id="secondary-nav"> <div class="row row--xl"> <ul class="secondary-nav__list list-unstyled"><li><a class="header-list-item-link" href="/category/news/"><span>News</span></a></li><li><a class="header-list-item-link" href="/category/sports/"><span>Sports</span></a></li><li><a class="header-list-item-link" href="/category/entertainment/"><span>Entertainment</span></a></li><li><a class="header-list-item-link" href="/category/life/"><span>Life</span></a></li><li><a class="header-list-item-link" href="/category/business/"><span>Money</span></a></li><li><a class="header-list-item-link" href="/category/opinion/"><span>Opinion</span></a></li><li><a class="header-list-item-link" href="http://postpandemic.nationalpost.com/" rel="noopener" target="_blank"><span>COVID Changemakers</span><span aria-hidden="true" class="external-link"></span></a></li><li><a class="header-list-item-link" href="/all-newspapers/"><span>All Newspapers</span></a></li><li><a class="header-list-item-link" href="/category/driving/"><span>Driving</span></a></li><li><a class="header-list-item-link" href="/category/healthing/"><span>Healthing</span></a></li><li><a class="header-list-item-link" href="/category/thegrowthop/"><span>The Growthop</span></a></li><li><a class="header-list-item-link" href="/shopping/"><span>Shopping</span></a></li><li><a class="header-list-item-link" href="/manage/"><span>Manage Print Subscription</span></a></li></ul> </div> </nav> <main id="main-content"> <article aria-labelledby="articleTitle" class="article-content-story article-content-story--story"> <div class="article-header__share-group hidden-medium-down"> <ul class="social-share social-share--icons social-share--column social-share--small list-unstyled"> <li class="social-share__item flex-align-justify-center"> <a class="social-share__link flex-align-justify-center" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "email", "social_share_loc": "share button - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="mailto:?Subject=I%20saw%20this%20on%20fortmcmurraytoday.com&amp;Body=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood"> <img alt="Share via email" class="social-share__icon" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-circle-email.svg" width="32"/> </a> </li> <li class="social-share__item flex-align-justify-center"> <a class="social-share__link flex-align-justify-center" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "facebook", "social_share_loc": "share button - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="http://www.facebook.com/sharer.php?u=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;display=popup" rel="noopener" target="_blank"> <img alt="Share on Facebook" class="social-share__icon" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-fb.svg" width="32"/> </a> </li> <li class="social-share__item flex-align-justify-center"> <a class="social-share__link flex-align-justify-center" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "twitter", "social_share_loc": "share button - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://twitter.com/share?url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;text=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo" rel="noopener" target="_blank"> <img alt="Share on Twitter" class="social-share__icon" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-tw.svg" width="32"/> </a> </li> <li class="social-share__item flex-align-justify-center share-button__wrapper share-button__wrapper--icon"> <button aria-expanded="false" aria-haspopup="true" class="share-button flex-align-justify-center" type="button"> <img alt="Open more share options" class="social-share__icon" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-circle-share.svg" width="32"/> </button> <section aria-labelledby="shareModalStoryHeaderTitle" aria-modal="true" class="share-button__modal" id="shareModalStoryHeader" role="dialog"> <button class="share-button__modal-close" type="button"> <img alt="Close" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/share-modal-icon-close.svg"/> </button> <h2 class="share-button__modal-title" id="shareModalStoryHeaderTitle"> Share this Story: <span class="hidden-medium-up">RCMP investigating human remains found in trail near Thickwood gazebo</span> </h2> <ul class="share-button__modal-items list-unstyled noskimlinks"> <li class="share-button__modal-item share-button__modal-item--link"> <a class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "Copy Link", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood"> <span aria-hidden="true" class="share-button__modal-item-icon"> <span class="copy"><svg height="48" version="1.1" viewBox="0 0 48 48" width="48" xmlns="http://www.w3.org/2000/svg"><g fill="none" fill-rule="evenodd" stroke="none" stroke-width="1"><g fill="#191919"><path d="M48 24C48 37.3 37.3 48 24 48 10.7 48 0 37.3 0 24 0 10.7 10.7 0 24 0 37.3 0 48 10.7 48 24"></path></g><path d="M32.5 28.7C32.5 28.4 32.4 28.1 32.1 27.8L29.3 25C29.1 24.8 28.8 24.6 28.4 24.6 28.1 24.6 27.7 24.8 27.5 25.1 27.5 25.1 27.6 25.2 27.7 25.3 27.9 25.5 28 25.6 28 25.6 28.1 25.7 28.1 25.7 28.2 25.9 28.3 26 28.4 26.1 28.4 26.2 28.4 26.3 28.4 26.4 28.4 26.6 28.4 26.9 28.3 27.2 28.1 27.5 27.8 27.7 27.5 27.9 27.1 27.9 27 27.9 26.9 27.8 26.8 27.8 26.7 27.8 26.5 27.7 26.4 27.6 26.3 27.6 26.2 27.5 26.2 27.4 26.1 27.4 26 27.3 25.9 27.1 25.8 27 25.7 26.9 25.6 26.9 25.3 27.2 25.2 27.5 25.2 27.9 25.2 28.2 25.3 28.5 25.6 28.8L28.3 31.6C28.6 31.8 28.9 31.9 29.2 31.9 29.6 31.9 29.9 31.8 30.2 31.6L32.1 29.6C32.4 29.4 32.5 29.1 32.5 28.7ZM23.1 19.3C23.1 18.9 23 18.6 22.7 18.4L20 15.6C19.7 15.3 19.4 15.2 19 15.2 18.7 15.2 18.4 15.3 18.1 15.6L16.2 17.5C15.9 17.8 15.8 18.1 15.8 18.4 15.8 18.8 15.9 19.1 16.2 19.3L18.9 22.1C19.2 22.4 19.5 22.5 19.9 22.5 20.2 22.5 20.6 22.3 20.8 22.1 20.8 22 20.7 22 20.6 21.8 20.4 21.7 20.3 21.6 20.3 21.5 20.2 21.5 20.2 21.4 20.1 21.3 20 21.2 19.9 21.1 19.9 20.9 19.9 20.8 19.9 20.7 19.9 20.6 19.9 20.2 20 19.9 20.2 19.7 20.5 19.4 20.8 19.3 21.1 19.3 21.3 19.3 21.4 19.3 21.5 19.3 21.6 19.4 21.7 19.4 21.9 19.5 22 19.6 22.1 19.7 22.1 19.7 22.2 19.8 22.3 19.9 22.4 20 22.5 20.1 22.6 20.2 22.6 20.3 22.9 20 23.1 19.6 23.1 19.3ZM33.9 26C34.7 26.7 35.1 27.6 35.1 28.7 35.1 29.8 34.7 30.7 33.9 31.4L32 33.4C31.2 34.1 30.3 34.5 29.2 34.5 28.2 34.5 27.3 34.1 26.5 33.4L23.8 30.6C23 29.8 22.6 28.9 22.6 27.9 22.6 26.8 23 25.8 23.8 25.1L22.6 23.9C21.9 24.7 20.9 25.1 19.9 25.1 18.8 25.1 17.9 24.7 17.1 23.9L14.3 21.2C13.6 20.4 13.2 19.5 13.2 18.4 13.2 17.4 13.6 16.5 14.4 15.7L16.3 13.8C17.1 13 18 12.6 19 12.6 20.1 12.6 21 13 21.8 13.8L24.5 16.6C25.3 17.3 25.6 18.2 25.6 19.3 25.6 20.4 25.3 21.3 24.5 22.1L25.6 23.3C26.4 22.5 27.3 22.1 28.4 22.1 29.5 22.1 30.4 22.4 31.2 23.2L33.9 26Z" fill="#FFFFFF" fill-rule="nonzero"></path></g></svg> </span> <span class="copied"><svg height="48" version="1.1" viewBox="0 0 48 48" width="48" xmlns="http://www.w3.org/2000/svg"><g fill="none" fill-rule="evenodd" stroke="none" stroke-width="1"><g fill="#005A8C"><path d="M48 24C48 37.3 37.3 48 24 48 10.7 48 0 37.3 0 24 0 10.7 10.7 0 24 0 37.3 0 48 10.7 48 24"></path></g><g fill="#FFFFFF" fill-rule="nonzero" transform="translate(15.000000, 12.000000)"><path d="M15.8 3L12 3C12 1.3 10.7 0 9 0 7.3 0 6 1.3 6 3L2.3 3C1 3 0 4 0 5.3L0 21.8C0 23 1 24 2.3 24L15.8 24C17 24 18 23 18 21.8L18 5.3C18 4 17 3 15.8 3ZM9 1.9C9.6 1.9 10.1 2.4 10.1 3 10.1 3.6 9.6 4.1 9 4.1 8.4 4.1 7.9 3.6 7.9 3 7.9 2.4 8.4 1.9 9 1.9ZM14.7 12.7L8 19.4C7.8 19.6 7.4 19.6 7.2 19.4L3.3 15.5C3.1 15.3 3.1 14.9 3.3 14.7L4.6 13.4C4.9 13.1 5.2 13.1 5.4 13.4L7.6 15.5 12.6 10.6C12.8 10.4 13.1 10.4 13.4 10.6L14.7 11.9C14.9 12.2 14.9 12.5 14.7 12.7Z"></path></g></g></svg> </span> </span> <span class="share-button__modal-item-text">Copy Link</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--email"> <a aria-label="Share via email" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "email", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="mailto:?Subject=I%20saw%20this%20on%20Fort%20McMurray%20Today&amp;Body=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood"> <img alt="Email" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-circle-email.svg" width="32"/> <span class="share-button__modal-item-text">Email</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--facebook"> <a aria-label="Share on Facebook" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "facebook", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="http://www.facebook.com/sharer.php?u=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;display=popup" rel="noopener" target="_blank"> <img alt="Facebook" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-fb.svg" width="32"/> <span class="share-button__modal-item-text">Facebook</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--twitter"> <a aria-label="Share on Twitter" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "twitter", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://twitter.com/share?url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;text=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo" rel="noopener" target="_blank"> <img alt="Twitter" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-tw.svg" width="32"/> <span class="share-button__modal-item-text">Twitter</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--reddit"> <a aria-label="Share on Reddit" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "reddit", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="http://www.reddit.com/submit?url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;smid=re-share&amp;title=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo" rel="noopener" target="_blank"> <img alt="Reddit" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-rdit.svg" width="32"/> <span class="share-button__modal-item-text">Reddit</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--pinterest"> <a aria-label="Share on Pinterest" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "pinterest", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://pinterest.com/pin/create/button/?url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;description=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo&amp;media=https%3A//smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg" rel="noopener" target="_blank"> <img alt="Pinterest" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-pin.svg" width="32"/> <span class="share-button__modal-item-text">Pinterest</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--linkedin"> <a aria-label="Share on LinkedIn" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "linkedin", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;title=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo" rel="noopener" target="_blank"> <img alt="LinkedIn" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-li.svg" width="32"/> <span class="share-button__modal-item-text">LinkedIn</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--tumblr"> <a aria-label="Share on Tumblr" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "tumblr", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://tumblr.com/widgets/share/tool?canonicalUrl=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;name=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo&amp;description" rel="noopener" target="_blank"> <img alt="Tumblr" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-tblr.svg" width="32"/> <span class="share-button__modal-item-text">Tumblr</span> </a> </li> </ul> </section> </li> </ul> </div> <header aria-label="Beginning of Article" class="article-header"> <nav aria-label="Breadcrumb" class="breadcrumbs"> <h2 class="visually-hidden">Breadcrumb Trail Links</h2> <ol class="breadcrumbs__items list-unstyled"> <li class="breadcrumbs__item"> <a class="breadcrumbs__item-link" href="/category/news/">News</a> </li> <li class="breadcrumbs__item"> <a aria-current="page" class="breadcrumbs__item-link" href="/category/news/local-news/">Local News</a> </li> </ol> </nav> <h1 class="article-title" id="articleTitle"> RCMP investigating human remains found in trail near Thickwood gazebo </h1> <div class="article-meta"> <div class="published-by"> <div class="visually-hidden">Author of the article:</div> <span class="published-by__author">Vincent McDermott</span> </div> <div class="published-date"> <div class="visually-hidden">Publishing date:</div> <span class="published-date__since">Mar 21, 2021</span>  •  <span class="updated-date__since">26 minutes ago</span>  •  <span class="published-date__word-count">1 minute read</span>  •  <span><a class="article-meta-comment-count smooth-hash-scroll" href="#comments-area"><img alt="comment bubble" class="comment-bubble" height="16" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/common-icon/comment_bubble.png" width="16"/>Join the conversation</a></span> </div> </div> <figure class="featured-image"> <picture class="featured-image__ratio featured-image-category__local-news"> <source media="(min-width: 1200px)" srcset="https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=564&amp;type=webp,
            https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=1128&amp;type=webp 2x" type="image/webp"/> <source media="(min-width: 1200px)" srcset="https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=564&amp;type=jpg,
            https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=1128&amp;type=jpg 2x" type="image/jpeg"/> <source media="(min-width: 768px)" srcset="https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=472&amp;type=webp,
            https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=944&amp;type=webp 2x" type="image/webp"/> <source media="(min-width: 768px)" srcset="https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=472&amp;type=jpg,
            https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=944&amp;type=jpg 2x" type="image/jpeg"/> <source media="(max-width: 767px)" srcset="https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=288&amp;type=webp,
            https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=576&amp;type=webp 2x" type="image/webp"/> <img alt="Wood Buffalo RCMP secure a trail, located near Silin Forest Road and Thicket Drive, on Sunday, March 21, 2021 after human remains were found in the area.  Sarah Williscraft/Fort McMurray Today/Postmedia Network" class="featured-image__image" height="667" src="https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=288" srcset="https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=288,
                    https://smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg?quality=90&amp;strip=all&amp;w=576 2x" width="1000"/> </picture> <figcaption class="featured-image__caption image-caption"> <span class="caption">Wood Buffalo RCMP secure a trail, located near Silin Forest Road and Thicket Drive, on Sunday, March 21, 2021 after human remains were found in the area. Sarah Williscraft/Fort McMurray Today/Postmedia Network</span> </figcaption> </figure> </header> <section class="article-content__content-group"> <h2 class="visually-hidden">Article content</h2> <p>Investigators are combing a trail system in Thickwood after human remains were discovered on Saturday afternoon.</p> <p>Wood Buffalo RCMP were told of the remains at 1:49 p.m. after they were discovered by people near the Rotary Club Gazebo at Thicket Drive and Silin Forest Road. Officers removed the remains and have closed off the area.</p> <div class="featured-video distroscale js-widget-distroscale" id="featured-video"> <div class="video-placeholder" placeholder=""> <div class="placeholder-inner"> <div class="ytp-spinner"> <div class="ytp-spinner-container"> <div class="ytp-spinner-rotator"> <div class="ytp-spinner-left"> <div class="ytp-spinner-circle"></div> </div> <div class="ytp-spinner-right"> <div class="ytp-spinner-circle"></div> </div> </div> </div> </div> </div> </div> <div fallback=""> <div class="video-fallback"> <div class="video-fallback-line-1">We apologize, but this video has failed to load.</div> <div>Try refreshing your browser.</div> </div> </div> <section class="player-wrapper" data-channel-id="" data-host="fortmcmurraytoday.prod.postmedia.digital" data-video-id="" id="video-container"> <header class="control-center"> <h5 class="control-heading"> <span class="control-heading--max">RCMP investigating human remains found in trail near Thickwood gazebo</span> <span class="control-heading--min">Back to video</span> </h5> <div class="control-btn-set"> <button aria-label="Minimize video" class="control-btn btn-toggle-visibility" id="toggle-video" type="button"> <svg aria-hidden="true" class="icon-desktop" viewBox="0 0 16 16" xmlns="http://www.w3.org/2000/svg"> <line class="icon-min" x1="0" x2="16" y1="8" y2="8"></line> <polygon class="icon-max" points="1,1, 1,15, 15,15, 15,1"></polygon> </svg> <svg aria-hidden="true" class="icon-mobile" viewBox="0 0 22 20" xmlns="http://www.w3.org/2000/svg"> <rect class="icon-min" height="16" width="16" x="1" y="1"></rect> <rect class="icon-min" height="11" width="11" x="10" y="8"></rect> <polyline class="icon-max" points=" 3,14, 11,6, 19,14"></polyline> </svg> </button> <button aria-label="Close sticky video" class="control-btn btn-close" id="close-video" type="button"> <img alt="Close sticky video" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/share-modal-icon-close.svg"/> </button> </div> </header> <div class="distroscale-wrapper" data-distroscale-htmlid="22507" data-evt="page-load" data-evt-typ="video-non-interaction" data-evt-val='{"control_fields": {"mparticle": {"keys": {"Video Autoplay": "Video Autoplay", "Video Location": "Video Location", "Video Platform": "Video Platform"}, "extra_keys": ["All Sub Sections"], "mp_custom_flags": ["Google.NonInteraction", "Google.Page"]}}, "Video Autoplay": "true", "Video Location": "story page", "Video Platform": "Distroscale"}' data-widget="distroscale" id="ds_default_anchor"> </div> </section> </div> <p>An autopsy is scheduled for Wednesday in Edmonton. Until the procedure is completed, an Alberta RCMP spokesperson says police cannot speculate on the deceased’s identity, or how and when death happened.</p> <p>Anyone with information about this incident or criminal activity in Wood Buffalo is asked to contact Wood Buffalo RCMP at 780-788-4040 or Crime Stoppers at 1-800-222-8477 (TIPS). Tips to Crime Stoppers are always anonymous and can be sent to tipsubmit.com.</p> <p>vmcdermott@postmedia.com</p> </section> <div class="ad__section-border article-content__ad-group"> <section class="ad"> <h2 class="visually-hidden">Advertisement</h2> <div class="ad__container"> <div class="ad__label"> <div class="ad__label__left"></div> <div class="ad__label__center"> Advertisement </div> <div class="ad__label__right"></div> </div> <div class="ad__inner" id="ad__inner-1"> <div class="ad__inner__container" data-ad="[[6,6],[1200,250],[1200,90],[970,90],[970,250],[728,90],[300,250]]" data-ad-interscroller="6x6" data-ad-loc="1" data-ad-mobile="[[6,6],[320,50],[300,50],[300,250]]" id="ad-1"> </div> <div class="ad__placeholder"> <div class="placeholder-inner"> This advertisement has not loaded yet, but your article continues below. </div> </div> </div> </div> </section> </div> <section class="article-content__content-group"> <h2 class="visually-hidden">Article content</h2> </section> <div class="article-content__content-group"> </div> <div class="article-content__ad-group"> </div> <section class="article-content__share-group article-delimiter" data-evt="beforeunload" data-evt-typ="scroll-depth" data-evt-val='{"control_fields": {"mparticle": {"mp_custom_flags": ["Google.NonInteraction", "Google.Page"], "extra_keys": ["Percentage of Page Viewed", "Percentage of Story Viewed"]}}}'> <h2 class="visually-hidden">Share this article in your social network</h2> <ul class="social-share social-share--icons social-share--row social-share--large list-unstyled"> <li class="social-share__item flex-align-justify-center"> <a class="social-share__link flex-align-justify-center" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "email", "social_share_loc": "share button - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="mailto:?Subject=I%20saw%20this%20on%20fortmcmurraytoday.com&amp;Body=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood"> <img alt="Share via email" class="social-share__icon" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-circle-email.svg" width="32"/> </a> </li> <li class="social-share__item flex-align-justify-center"> <a class="social-share__link flex-align-justify-center" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "facebook", "social_share_loc": "share button - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="http://www.facebook.com/sharer.php?u=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;display=popup" rel="noopener" target="_blank"> <img alt="Share on Facebook" class="social-share__icon" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-fb.svg" width="32"/> </a> </li> <li class="social-share__item flex-align-justify-center"> <a class="social-share__link flex-align-justify-center" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "twitter", "social_share_loc": "share button - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://twitter.com/share?url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;text=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo" rel="noopener" target="_blank"> <img alt="Share on Twitter" class="social-share__icon" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-tw.svg" width="32"/> </a> </li> <li class="social-share__item flex-align-justify-center share-button__wrapper share-button__wrapper--icon"> <button aria-expanded="false" aria-haspopup="true" class="share-button flex-align-justify-center" type="button"> <img alt="Open more share options" class="social-share__icon" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-circle-share.svg" width="32"/> </button> <section aria-labelledby="shareModalStoryFooterTitle" aria-modal="true" class="share-button__modal" id="shareModalStoryFooter" role="dialog"> <button class="share-button__modal-close" type="button"> <img alt="Close" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/share-modal-icon-close.svg"/> </button> <h2 class="share-button__modal-title" id="shareModalStoryFooterTitle"> Share this Story: <span class="hidden-medium-up">RCMP investigating human remains found in trail near Thickwood gazebo</span> </h2> <ul class="share-button__modal-items list-unstyled noskimlinks"> <li class="share-button__modal-item share-button__modal-item--link"> <a class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "Copy Link", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood"> <span aria-hidden="true" class="share-button__modal-item-icon"> <span class="copy"><svg height="48" version="1.1" viewBox="0 0 48 48" width="48" xmlns="http://www.w3.org/2000/svg"><g fill="none" fill-rule="evenodd" stroke="none" stroke-width="1"><g fill="#191919"><path d="M48 24C48 37.3 37.3 48 24 48 10.7 48 0 37.3 0 24 0 10.7 10.7 0 24 0 37.3 0 48 10.7 48 24"></path></g><path d="M32.5 28.7C32.5 28.4 32.4 28.1 32.1 27.8L29.3 25C29.1 24.8 28.8 24.6 28.4 24.6 28.1 24.6 27.7 24.8 27.5 25.1 27.5 25.1 27.6 25.2 27.7 25.3 27.9 25.5 28 25.6 28 25.6 28.1 25.7 28.1 25.7 28.2 25.9 28.3 26 28.4 26.1 28.4 26.2 28.4 26.3 28.4 26.4 28.4 26.6 28.4 26.9 28.3 27.2 28.1 27.5 27.8 27.7 27.5 27.9 27.1 27.9 27 27.9 26.9 27.8 26.8 27.8 26.7 27.8 26.5 27.7 26.4 27.6 26.3 27.6 26.2 27.5 26.2 27.4 26.1 27.4 26 27.3 25.9 27.1 25.8 27 25.7 26.9 25.6 26.9 25.3 27.2 25.2 27.5 25.2 27.9 25.2 28.2 25.3 28.5 25.6 28.8L28.3 31.6C28.6 31.8 28.9 31.9 29.2 31.9 29.6 31.9 29.9 31.8 30.2 31.6L32.1 29.6C32.4 29.4 32.5 29.1 32.5 28.7ZM23.1 19.3C23.1 18.9 23 18.6 22.7 18.4L20 15.6C19.7 15.3 19.4 15.2 19 15.2 18.7 15.2 18.4 15.3 18.1 15.6L16.2 17.5C15.9 17.8 15.8 18.1 15.8 18.4 15.8 18.8 15.9 19.1 16.2 19.3L18.9 22.1C19.2 22.4 19.5 22.5 19.9 22.5 20.2 22.5 20.6 22.3 20.8 22.1 20.8 22 20.7 22 20.6 21.8 20.4 21.7 20.3 21.6 20.3 21.5 20.2 21.5 20.2 21.4 20.1 21.3 20 21.2 19.9 21.1 19.9 20.9 19.9 20.8 19.9 20.7 19.9 20.6 19.9 20.2 20 19.9 20.2 19.7 20.5 19.4 20.8 19.3 21.1 19.3 21.3 19.3 21.4 19.3 21.5 19.3 21.6 19.4 21.7 19.4 21.9 19.5 22 19.6 22.1 19.7 22.1 19.7 22.2 19.8 22.3 19.9 22.4 20 22.5 20.1 22.6 20.2 22.6 20.3 22.9 20 23.1 19.6 23.1 19.3ZM33.9 26C34.7 26.7 35.1 27.6 35.1 28.7 35.1 29.8 34.7 30.7 33.9 31.4L32 33.4C31.2 34.1 30.3 34.5 29.2 34.5 28.2 34.5 27.3 34.1 26.5 33.4L23.8 30.6C23 29.8 22.6 28.9 22.6 27.9 22.6 26.8 23 25.8 23.8 25.1L22.6 23.9C21.9 24.7 20.9 25.1 19.9 25.1 18.8 25.1 17.9 24.7 17.1 23.9L14.3 21.2C13.6 20.4 13.2 19.5 13.2 18.4 13.2 17.4 13.6 16.5 14.4 15.7L16.3 13.8C17.1 13 18 12.6 19 12.6 20.1 12.6 21 13 21.8 13.8L24.5 16.6C25.3 17.3 25.6 18.2 25.6 19.3 25.6 20.4 25.3 21.3 24.5 22.1L25.6 23.3C26.4 22.5 27.3 22.1 28.4 22.1 29.5 22.1 30.4 22.4 31.2 23.2L33.9 26Z" fill="#FFFFFF" fill-rule="nonzero"></path></g></svg> </span> <span class="copied"><svg height="48" version="1.1" viewBox="0 0 48 48" width="48" xmlns="http://www.w3.org/2000/svg"><g fill="none" fill-rule="evenodd" stroke="none" stroke-width="1"><g fill="#005A8C"><path d="M48 24C48 37.3 37.3 48 24 48 10.7 48 0 37.3 0 24 0 10.7 10.7 0 24 0 37.3 0 48 10.7 48 24"></path></g><g fill="#FFFFFF" fill-rule="nonzero" transform="translate(15.000000, 12.000000)"><path d="M15.8 3L12 3C12 1.3 10.7 0 9 0 7.3 0 6 1.3 6 3L2.3 3C1 3 0 4 0 5.3L0 21.8C0 23 1 24 2.3 24L15.8 24C17 24 18 23 18 21.8L18 5.3C18 4 17 3 15.8 3ZM9 1.9C9.6 1.9 10.1 2.4 10.1 3 10.1 3.6 9.6 4.1 9 4.1 8.4 4.1 7.9 3.6 7.9 3 7.9 2.4 8.4 1.9 9 1.9ZM14.7 12.7L8 19.4C7.8 19.6 7.4 19.6 7.2 19.4L3.3 15.5C3.1 15.3 3.1 14.9 3.3 14.7L4.6 13.4C4.9 13.1 5.2 13.1 5.4 13.4L7.6 15.5 12.6 10.6C12.8 10.4 13.1 10.4 13.4 10.6L14.7 11.9C14.9 12.2 14.9 12.5 14.7 12.7Z"></path></g></g></svg> </span> </span> <span class="share-button__modal-item-text">Copy Link</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--email"> <a aria-label="Share via email" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "email", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="mailto:?Subject=I%20saw%20this%20on%20Fort%20McMurray%20Today&amp;Body=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood"> <img alt="Email" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-circle-email.svg" width="32"/> <span class="share-button__modal-item-text">Email</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--facebook"> <a aria-label="Share on Facebook" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "facebook", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="http://www.facebook.com/sharer.php?u=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;display=popup" rel="noopener" target="_blank"> <img alt="Facebook" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-fb.svg" width="32"/> <span class="share-button__modal-item-text">Facebook</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--twitter"> <a aria-label="Share on Twitter" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "twitter", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://twitter.com/share?url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;text=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo" rel="noopener" target="_blank"> <img alt="Twitter" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-tw.svg" width="32"/> <span class="share-button__modal-item-text">Twitter</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--reddit"> <a aria-label="Share on Reddit" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "reddit", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="http://www.reddit.com/submit?url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;smid=re-share&amp;title=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo" rel="noopener" target="_blank"> <img alt="Reddit" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-rdit.svg" width="32"/> <span class="share-button__modal-item-text">Reddit</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--pinterest"> <a aria-label="Share on Pinterest" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "pinterest", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://pinterest.com/pin/create/button/?url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;description=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo&amp;media=https%3A//smartcdn.prod.postmedia.digital/nexus/wp-content/uploads/2021/03/crime-scene-march-21-3.jpg" rel="noopener" target="_blank"> <img alt="Pinterest" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-pin.svg" width="32"/> <span class="share-button__modal-item-text">Pinterest</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--linkedin"> <a aria-label="Share on LinkedIn" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "linkedin", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;title=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo" rel="noopener" target="_blank"> <img alt="LinkedIn" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-li.svg" width="32"/> <span class="share-button__modal-item-text">LinkedIn</span> </a> </li> <li class="share-button__modal-item share-button__modal-item--tumblr"> <a aria-label="Share on Tumblr" class="flex-align-center share-button__modal-item-link" data-evt="click" data-evt-typ="Share Article" data-evt-val='{"social_share_channel": "tumblr", "social_share_loc": "social widget - story page", "control_fields": {"mparticle": {"keys": {"social_share_channel": "Share Channel", "social_share_loc": "Share Location On Page"}, "mp_event_type": "Social", "extra_keys": ["Article ID"]}}}' href="https://tumblr.com/widgets/share/tool?canonicalUrl=https://fortmcmurraytoday.com/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood&amp;name=RCMP%20investigating%20human%20remains%20found%20in%20trail%20near%20Thickwood%20gazebo&amp;description" rel="noopener" target="_blank"> <img alt="Tumblr" class="share-button__modal-item-img" height="32" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-tblr.svg" width="32"/> <span class="share-button__modal-item-text">Tumblr</span> </a> </li> </ul> </section> </li> </ul> </section> <div class="article-content__ad-group"> </div> <div class="widget article-content__widget-group"> <section aria-label="Most commented articles" class="comments__carousel divider--top divider--bottom"> <div class="comments__carousel-viafoura-container" data-comments-ad-ref="off" data-comments-ad-size="[[300,250]]" data-comments-ad-size-mobile="[[300,50],[300,250],[320,50]]" data-comments-ad-target='{"prtn":["viafoura"]}' data-sso-carousel="viafoura" data-sso-marker="" data-viafoura=""> </div> </section>  </div> <div class="widget article-content__widget-group article-content__widget-group--slot1"> <section aria-labelledby="LatestNationalStories5566126046907304287822824581699316" class="list-widget list-widget-trending list" data-async=""> <div class="widget-title widget-title--list-widget flex-align-center"> <h2 class="widget-title__heading" id="LatestNationalStories5566126046907304287822824581699316"> Latest National Stories </h2> </div> <div class="list-widget__content list--loading" data-content-id="0417980f-6cb9-411e-99d9-f9f9cf20e773" data-list-id="750b25a8-e919-4c89-97b7-38feb92870d9" data-list-max="5" data-list-min="3" data-list-name="latest-national-stories" data-list-native_ad_enabled="True" data-list-native_ad_position="2" data-list-pos="" data-list-render="widget" data-list-type="wcm-dynamic-list" data-remove-duplication="" data-template-name="feed-card-list" id="0417980f-6cb9-411e-99d9-f9f9cf20e773"></div> <div class="visually-hidden js-0417980f-6cb9-411e-99d9-f9f9cf20e773-native"> <article class="ad__native" data-list-position="2" data-native=""> <section class="ad"> <h2 class="visually-hidden">Advertisement</h2> <div class="ad__container"> <div class="ad__label"> <div class="ad__label__left"></div> <div class="ad__label__center"> Story continues below </div> <div class="ad__label__right"></div> </div> <div class="ad__inner ad__inner--native" id="ad__inner-native-1"> <div class="ad__inner__container" data-ad="[[5,5]]" data-ad-loc="1" data-ad-ref="off" id="ad-native-1"> </div> <div class="ad__placeholder"> <div class="placeholder-inner"> This advertisement has not loaded yet, but your article continues below. </div> </div> </div> </div> </section> </article> </div> </section> </div> <div class="widget article-content__widget-group article-content__widget-group--slot2"> <section aria-labelledby="NewsNear#city#470094374749979479861484711827757" class="list-widget list-widget--regional list" data-async=""> <div class="widget-title widget-title--list-widget flex-align-center"> <h2 class="widget-title__heading" id="NewsNear#city#470094374749979479861484711827757"> News Near Fort McMurray </h2> </div> <div class="list-widget__content list--loading" data-content-id="0417980f-6cb9-411e-99d9-f9f9cf20e773" data-hide-on-overlap=".ad__container" data-list-id="0000-0000" data-list-max="4" data-list-min="2" data-list-name="news" data-list-pos="" data-list-render="widget" data-list-type="category" data-remove-duplication="" data-template-name="regional-card-list"></div> </section> </div> <div class="article-content__widget-group"> <section aria-labelledby="flyerWidgetLabel" class="widget js-widget-flyercity"> <h2 class="section-title section-title--story js-widget-flyercity" id="flyerWidgetLabel"> This Week in Flyers </h2> <div class="widget-flyercity js-widget-flyercity"> <div data-mod-id="flyertown_module_14859" data-url-param="14859" data-widget="flyercity"></div> </div> </section> </div> <footer aria-label="Article Comments" class="article-footer"> <section class="comments__section" id="comments"> <h3 class="widget-title comments-anchor" id="comments-area">Comments</h3> <p class="comments__section-disclaimer"> Postmedia is committed to maintaining a lively but civil forum for discussion and encourage all readers to share their views on our articles. Comments may take up to an hour for moderation before appearing on the site. We ask you to keep your comments relevant and respectful. We have enabled email notifications—you will now receive an email if you receive a reply to your comment, there is an update to a comment thread you follow or if a user you follow comments. Visit our <a href="https://pages.postmedia.com/community-guidelines/">Community Guidelines</a> for more information and details on how to adjust your <a href="https://pages.postmedia.com/community-guidelines/#FAQ8">email</a> settings. </p> <div class="comments__section-viafoura-container" data-comments-ad-ref="off" data-comments-ad-size="[[300,250]]" data-comments-ad-size-mobile="[[300,50],[300,250],[320,50]]" data-comments-ad-target='{"prtn":["viafoura"]}' data-sso-commenting="viafoura" data-sso-marker="" data-viafoura=""> </div> </section>  </footer> </article> </main> <footer class="footer" id="footer"> <div class="row"> <div class="col-xs-12"> <div class="footer__group"> <nav aria-labelledby="list-primary-cat" class="footer__links-list footer__links-list--primary"> <h3 class="visually-hidden" id="list-primary-cat">Categories</h3> <ul class="list-unstyled"> <li> <a class="header-list-item-link" href="/category/news/"> <span>News</span> </a> </li> <li> <a class="header-list-item-link" href="/category/sports/"> <span>Sports</span> </a> </li> <li> <a class="header-list-item-link" href="/category/entertainment/"> <span>Entertainment</span> </a> </li> <li> <a class="header-list-item-link" href="/category/life/"> <span>Life</span> </a> </li> <li> <a class="header-list-item-link" href="/category/business/"> <span>Money</span> </a> </li> <li> <a class="header-list-item-link" href="/category/opinion/"> <span>Opinion</span> </a> </li> <li> <a class="header-list-item-link" href="http://postpandemic.nationalpost.com/" rel="noopener" target="_blank"> <span>COVID Changemakers</span> <span aria-hidden="true" class="external-link"></span> </a> </li> </ul> </nav> <hr class="footer__break hidden-large-up"/> <section class="social-follow footer__social-media"> <h3 class="social-follow__title">Follow the Fort McMurray Today</h3> <ul class="social-follow__links-list"> <li class="social-follow__link-item"> <a href="http://www.twitter.com/Fortmactoday" rel="noopener" target="_blank"> <img alt="Visit our Twitter page in a new tab" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/share-icons/icon-soc-tw.svg"/> </a> </li> </ul> </section> </div> <hr class="footer__break"/> <nav aria-labelledby="secondary-short-list-links" class="footer__links-list footer__links-list--secondary"> <h3 class="visually-hidden" id="secondary-short-list-links">Secondary Links</h3> <ul class="list-unstyled"> <li> <a href="http://www.postmediasolutions.com/"> Advertise With Us </a> </li> <li> <a href="https://adregistry.postmedia.com/"> Digital Ad Registry </a> </li> <li> <a href="/sitemap/"> Site Map </a> </li> <li> <a href="/contact/"> Contact </a> </li> <li> <a aria-label="Link will open in a new tab" href="https://pages.postmedia.com/privacy-statement/" rel="noopener" target="_blank"> Privacy - Updated </a> </li> <li> <a href="https://pages.postmedia.com/termsofservice/"> Terms of Use </a> </li> <li> <a href="/copyright/"> Copyright </a> </li> </ul> </nav> <div class="footer__copyright"> <a class="footer__brand-logo" href="https://www.postmedia.com/brands"> <img alt="Visit the Postmedia Brands page" src="https://dcs-static.prod.postmedia.digital/6.0.2/websites/images/logo-postmedia.svg"/> </a> <p>365 Bloor Street East, Toronto, Ontario, M4W 3L4</p> <p> © 2021 Fort McMurray Today, a division of Postmedia Network Inc. All rights reserved. Unauthorized distribution, transmission or republication strictly prohibited. </p> </div> <a class="hidden" href="/news/local-news/rcmp-investigating-human-remains-found-in-forested-area-near-thickwood/wcm/0417980f-6cb9-411e-99d9-f9f9cf20e773/amp/" title="RCMP investigating human remains found in trail near Thickwood gazebo"></a> </div> </div> </footer> <div class="article-counter" id="article-counter"></div> <section aria-describedby="consentDialogDesc" aria-labelledby="consentDialogTitle" class="consent__banner" hidden=""> <div class="consent__info-column"> <h2 class="consent__title" id="consentDialogTitle">Notice for the Postmedia Network</h2> <p class="consent__info" id="consentDialogDesc"> This website uses cookies to personalize your content (including ads), and allows us to analyze our traffic. Read more about <a href="https://pages.postmedia.com/cookie-policy/" rel="noopener" target="_blank">cookies here</a>. By continuing to use our site, you agree to our <a href="https://pages.postmedia.com/termsofservice/" rel="noopener" target="_blank">Terms of Service</a> and <a href="https://pages.postmedia.com/privacy-statement" rel="noopener" target="_blank">Privacy Policy</a>. </p> </div> <div class="consent__button-column"> <button class="consent__button" data-evt="click" data-evt-typ="GDPR Consent Banner View" data-evt-val='{"control_fields":{
               "mparticle":{"mp_custom_flags": ["Google.NonInteraction", "Google.Page"],"mp_event_type": "UserContent"}}}' type="button"> OK </button> </div> </section> <script async="" nomodule="" src="https://dcs-static.prod.postmedia.digital/6.0.2/CACHE/js/output.d1e1ec39747a.js"></script> <script async="" src="https://dcs-static.prod.postmedia.digital/6.0.2/CACHE/js/output.19589b007e97.js" type="module"></script> </body></html>